Mission

The Search Function

9 posts in this topic

I am a big fan of search functions on forums as I sometimes use them to type in things I want to use later or copy into my notes. But have you ever had the problem where you search a forum and you come up with a thread with dozens of pages of replies? The forum (so far) doesn't take you directly to the page where the search term came up. However, I stumbled across something that may be helpful just now.

If you are inside of a particular thread, you can search that thread only and the search function will produce all the posts that contain the word you want. So rather than clicking through dozens of the pages, all you have to do is select the thread containing the term and do a second search within that thread. It kinda' sucks because you have to do two searches, but it saves a lot of work on subjects like the two "Random Topics" threads in the Beyond Pyracy forum.

Share this post


Link to post
Share on other sites

Um sorry about that. The search feature doesn't actually work yet. I've got to get under the hood, manually run a few scripts and build the database for it. It's a little involved, but on my todo list. . .

Share this post


Link to post
Share on other sites

Hey Mission, would you consider this fixed and working now?

Share this post


Link to post
Share on other sites

Hey Mission, would you consider this fixed and working now?

The search function seems to be working fine now.

My only gripe would be that it was actually a little (but only a wee, small little) better when it only found the threads containing the search word when searching on the forum level and the posts inside the threads when searching on the thread level.

Minor, minor, minor...probably not even worth the time it would cost you to investigate. In fact, it's really more of a "my 2ยข" thing than an actual complaint.

Share this post


Link to post
Share on other sites

Okay I'll add that refinement to the list, drop it down to the bottom of the pile, close, unpin this topic and let it go away.

Share this post


Link to post
Share on other sites

The search function should be working now. . .

Share this post


Link to post
Share on other sites

Yep, it appears to be. Thanks for fixing it again. It's a nice feature to have available, especially in Twill.

Share this post


Link to post
Share on other sites

Well it looks like we've got another search engine issue. . . I'll get on it as soon as I can.

Ahoy, Stynky!

I tried to search for the rope sandals just now, and got this error message.

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@pyracy.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Share this post


Link to post
Share on other sites

I get messages like that occasionally, but when hit the backpage key and retry it, it works fine.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now